Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #1661

    AstroCat
    Participant

    Hey all,

    While attempting to set up the cFS (initially on a Raspberry Pi, but I have since replicated this on a normal x86 linux machine), I’ve run into trouble getting tables to work. While building the cFS works fine after changing the architecture in a couple makefiles, I run into the same error as khldragon in this thread: https://coreflightsystem.org/forums/topic/cubesatsraspberry-pi/#post-1654.
    CFE_TBL:Load-App(13) Fail to load Tbl ‘HK_APP.CopyTable’ from ‘/cf/apps/hk_cpy_tbl.tbl’ (Stat=0xCC000020)

    For every table I attempt to load in, I receive the 0xCC000020 error, which indicates that “The calling Application tried to load a table using a file whose header indicated that it was for a different table.”

    I have made no configuration changes, and am following the instructions in the cFS Deployment Guide for integrating the applications and building the system.
    To reproduce,

    1. download the cFE, OSAL, and any cFS application requiring tables (e.g. HK) from sourceforge
    2. place the application in the top-level “apps” directory (renaming to its abbreviation – hk) and the OSAL in the osal directory
    3. add the application name to THE_APPS and THE_TBLS in build/cpu1/Makefile
    4. add the application to build/cpu1/exe/cfe_es_startup.scr (CFE_APP, /cf/apps/sch_lab.so, SCH_Lab_AppMain, SCH_LAB_APP, 80, 8192, 0x0, 0;)
    5. run make clean , make config , make in build/cpu1
    6. go to build/cpu1/exe/and sudo ./core-linux.bin PO 1

    This may very well be something silly like a mission name mismatch, but I’m unfamiliar with the software and would appreciate some guidance.

    Thanks!

    • This topic was modified 1 year, 11 months ago by  AstroCat.
    #1665

    AstroCat
    Participant

    RESOLVED

    This was a rookie mistake on my part. When adding a mission app to the startup script (HK, in this example), I set its CFE Name (column 4) to HK_APP. This seemed logical at first, because the (SAMPLE/CI_LAB/TO_LAB/SCH_LAB) apps are loaded as (SAMPLE/TO_LAB/CI_LAB/SCH_LAB)_APP. However, the code generating the table was creating the header for an app with a CFE name of just HK. After removing the _APP in column 4, the tables loaded just fine.

    Hopefully this helps khldragon and anybody else getting started with the software. If any cFS developers read this, I would recommend mentioning the difference somewhere in documentation since it seems like an easy (and potentially common) mistake to make.

    #1702

    the_other_james
    Moderator

    Hi AstroCat! This is an excellent question and answer.

    We are looking into reorganizing this site a bit which will include trying to funnel questions like this into the Q/A section (https://coreflightsystem.org/questions/). We hope that this will make it easier for new users to find previously answered questions and also give veterans a single place to go to help out. It also lets folks easily see what questions are in need of answers (thanks for answering your own question!).

    Would you mind adding this questing and answer to the Q/A section? Don’t worry if you are too busy, I can just add it myself. But I would prefer you to add it so that your user account is associated with it instead of mine.

    Thanks!

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.